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Type: you work with it every day, in almost every document. 
You count on fonts, small pieces of software, to perform reliably in different applications, 

on different platforms, and with various types of output. Your customers choose fonts based 

on design needs, as a way of expressing themselves and getting their messages across. It’s 

your job to ensure they print. Understanding different font formats, how Adobe® Creative 

Suite 2 interacts with fonts, and how to avoid pitfalls can help you print customer files 

smoothly and efficiently. 

Adobe Creative Suite 2 applications support 

OpenType, Type 1, and TrueType fonts in 

Windows and Mac OS X. Adobe InDesign® 

CS2, Adobe Photoshop® CS2, and Adobe 

Illustrator® CS2 provide strong support for 

OpenType fonts, in particular, and better 

integration of type between the applications, 

especially in PDF workflows. 

W o r k in  g  wi  t h  O p e nT  y p e  F o n t s

OpenType fonts offer several advantages 

over traditional Type 1 and TrueType fonts. 

They are cross-platform, support alter-

nate glyphs for advanced typography, can 

include characters for more languages in a 

single font, and are compatible with most 

applications and with all recent operating 

systems. Not all OpenType fonts support 

the same features, but they all make it easier 

to transfer a document from one computer 

to another.

Adobe Systems worked with Microsoft to 

develop the cross-platform OpenType font 

format, which is based on existing Type 1 

and TrueType technology. Adobe applica-

tions support both kinds of OpenType fonts: 

those containing PostScript® data, such as 

OpenType fonts developed by Adobe (with 

the suffix .otf), and those based on TrueType 

fonts (with a .ttf or .otf suffix). Although 

OpenType fonts can have either of two dif-

ferent outline formats, everything else about 

the font file is the same, making it easier for 

application and system vendors to support 

the advanced language and typographic 

capabilities of OpenType fonts. Adobe has 

converted its entire font library to OpenType 

fonts, and several other vendors now provide 

their libraries in OpenType format, as well.

A single file contains the outline and metrics 

data for each OpenType font, simplifying file 

management. The same font file works on 

Type in Adobe Creative Suite 2
How Creative Suite applications work with fonts
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both Macintosh and Windows computers, making documents much 

more portable. And OpenType fonts don’t require special handling; they 

can be installed and used alongside PostScript Type 1 and TrueType 

fonts. They’re natively supported in the latest operating systems—Mac 

OS X, Windows 2000, and Windows XP; they are also supported in older 

Mac OS and Windows operating systems with ATM® Light™.

Previously, a typical Western PostScript font was limited to 256 glyphs, 

which are the specific forms that characters can take. Therefore, you 

needed an extra font to access the standard “expert set” glyphs that 

didn’t fit in the main font file. And if there were more special alternates 

(swash caps or special ligatures, for example), those would need further 

separate fonts. In an OpenType font, all related glyphs are in a single 

font file. A single OpenType font can include more than 65,000 glyphs, 

so there’s plenty of room for nonstandard glyphs such as old-style 

figures, true small capitals, fractions, and a full range of ligatures. The 

OpenType text model means that no matter what alternate glyphs you 

use, you can check spelling and use find and change features as if you 

were using the standard glyph set. 

You use special OpenType formatting to access alternate glyphs 

or positioning in applications that support these features, such as 

InDesign, Illustrator and Photoshop. Each character has a default 

glyph and position. When you apply a layout feature to one or more 

characters, the positioning of glyphs may change, or a different glyph 

may be substituted. For example, if you apply the small capitals feature 

to a lowercase “a,” the small capital “a” glyph is substituted. Applica-

tions that don’t support advanced OpenType layout features can still 

access the basic glyph sets, which are analogous to those in traditional 

PostScript Type 1 fonts.

OpenType fonts are based on Unicode, an international multi-byte 

character encoding that covers virtually all of the world’s languages. 

These fonts can include multiple language character sets in one font, 

making multilingual typography easier. 

Note: OpenType ordinal and fraction features should not be applied 

globally to text, but only to the actual ordinals and fractions. Newer 

fonts that have “arbitrary fractions” capability may superscript stand-

alone numbers if you format all the text as fractions. This is especially 

a problem with font versioning, if a newer version of a font has been 

revised to support arbitrary fractions. For more information, see 

Adobe’s OpenType User Guide and OpenType Read Me file at http://

store.adobe.com/type/browser/pdfs/OTGuide.pdf

As with PostScript Type 1 or TrueType fonts, Adobe recommends you 

obtain copies of your customer’s OpenType fonts when they submit 

jobs to prevent discrepancies in versions of the font. However, it is still 

your responsibility as a service provider to own a license in order to 

legally install and use the font. For information, see http://www.adobe.

com/type/topics/licenseqa.html.

Continued from page 1
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The Adobe Solutions Network (ASN) manages programs to 

educate and prepare businesses that support users of Adobe 

products. If you are a Print Service Provider, Trainer, Developer, 

System Integrator,  or Value-Added Reseller, and would like to 

learn more about the ASN, please visit http://partners.adobe.

com for details.

Past Issues of ReadMe Now: You can download past issues of 

this newsletter from a special ASN area on Adobe’s Web site: 

http://partners.adobe.com/asn/service/private/techbenefits.jsp

ASN Customer Services E-mail: asnprovider@adobe.com

Resources for service providers: http://www.adobe.com/asnprint

ReadMe Now is produced with Adobe® InDesign® and Adobe® Acrobat®.

Adobe, the Adobe logo, Acrobat, Adobe Premiere, Adobe Type Manager, ATM, Dis-
tiller, Exchange, GoLive, FrameMaker, InDesign, Illustrator,  PageMaker, Photoshop,  
PostScript, and Version Cue are trademarks of Adobe Systems Incorporated. Apple 
Macintosh, and Power Macintosh are trademarks of Apple Computer, Inc., regis-
tered in the U.S. and other countries. Microsoft and Windows are either registered 
trademarks or trademarks of Microsoft Corporation. All other trademarks are the 
property of their respective owners. 

© 2005 Adobe Systems Incorporated. All rights reserved. 

Understanding OpenType font names

All OpenType fonts from Adobe include the standard range of Latin 

characters used throughout western countries, as well as several inter-

national characters, including the euro currency and litre symbols. 

Western OpenType fonts named “Pro” add a full range of accented 

characters to support central European languages, such as Turkish and 

Polish. Many also contain Cyrillic and Greek character extensions.

To see which features a font includes, visit http://store.adobe.com/

type/main.html and browse fonts; cyan icons indicate which features 

are included. Alternatively, in InDesign or Illustrator, use the Glyph 

palette menu to see which features are in a font; select those features 

to see which glyphs are used for them. The OpenType User Guide 

clearly spells out which OpenType layout features are supported by 

which Adobe applications.

In the Adobe store (http://store.adobe.com/type/main.html), you can 

see which alternative glyphs are included with a font. Click the More 

Info tab to see a detailed list of linguistic character sets supported, as 

well as a link to a PDF file showing all the glyphs in the font, sorted 

by category.

http://store.adobe.com/type/browser/pdfs/OTGuide.pdf
http://store.adobe.com/type/browser/pdfs/OTGuide.pdf
http://www.adobe.com/type/topics/licenseqa.html
http://www.adobe.com/type/topics/licenseqa.html
http://partners.adobe.com
http://partners.adobe.com
http://partners.adobe.com/asn/service/private/techbenefits.jsp
http://www.adobe.com/asnprint
http://store.adobe.com/type/main.html
http://store.adobe.com/type/main.html
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In Mac OS X 10.2.5 and earlier, large OpenType fonts might cause 

a print job to fail; Mac OS X 10.2.6 resolves this issue. In general, 

however, OpenType fonts present no special challenges for printing 

or for creating Adobe PDF files. Once OpenType fonts are part of the 

PostScript print stream or are in a PDF file, they appear no different 

to PostScript RIPS than Type 1 or TrueType fonts.

For detailed information about OpenType fonts, visit http://www.

adobe.com/type/opentype.

W o r k in  g  wi  t h  T y p e  1  F o n t s

For many years, PostScript Type 1 fonts proved reliable and conve-

nient for printers. However, the format has its limitations. A single 

Type 1 font can include only 256 glyphs, and it doesn’t use a Unicode 

encoding. The Type 1 font format doesn’t provide typographic exten-

sions for languages that require them. The font files aren’t designed 

to be cross-platform, and each font requires multiple files. For all of 

these reasons, Adobe has moved its type library from Type 1 fonts to 

OpenType fonts.

Adobe stopped developing new Type 1 fonts in 1999, but Adobe 

Creative Suite 2 continues to support them. Likewise, the Multiple 

Master Type 1 fonts are no longer available, but still work in current 

Adobe applications. Unless there is a very specific reason for choosing 

Type 1 fonts, Adobe recommends licensing OpenType fonts as the best 

long-term investment.

Though Windows Type 1 fonts are not supported by the Mac OS X 

operating system, you can use the fonts with Creative Suite applications 

in Mac OS X. To use them with the applications, copy the files to the 

application’s font folder or the Adobe common font folder. 

W o r k in  g  wi  t h  Tr  u e T y p e  F o n t s

TrueType fonts have long been the alternative to Type 1 fonts. The 

system fonts that come with Windows XP and Mac OS X are TrueType 

fonts. Though they also have limitations, True Type fonts are supported 

in Adobe Creative Suite 2 applications. 

Though you can’t use Macintosh TrueType fonts on Windows, you 

can use Windows TrueType fonts in Mac OS X. To use them in Mac 

OS X, place the Windows TrueType fonts in one of the standard font 

locations, or activate them in Suitcase or Font Reserve. 

W o r k in  g  wi  t h  f o n t s  in   A d o b e  C r e at i v e  S u i t e  2

Typography is a priority for Adobe, so the Adobe Creative Suite 

2 applications provide strong support for OpenType, Type 1 and 

TrueType fonts, extended typography support, and consistent font 

usage throughout the workflow. More than 180 OpenType fonts are 

Continued from page 2

bundled with Adobe Creative Suite 2. (To see which fonts are included, 

visit http://www.adobe.com/products/creativesuite/type.html#.)

Photoshop CS2 and Illustrator CS2 have the same text engine, so you 

can produce quality vector type in Photoshop. 

Adobe Creative Suite 2 applications provide better font support for 

PDF workflows. When you exported Adobe PDF docuemnts from 

earlier versions of InDesign, fonts were embedded as CID-keyed 

(Character ID) Type 1 or TrueType fonts, but some non Adobe “Post-

Script compatible” RIPs had problems processing CID-encoded fonts 

correctly. Neither InDesign CS2 nor Illustrator CS2 convert fonts to 

CID-encoded fonts when exporting to PDF unless special OpenType 

Continued on page 4

S ys t e m  F o n t s  in   Mac    OS   X

In Mac OS X, some of the system fonts, which are stored in special 

packaging that will work on a Unix File System (UFS), are called 

dFonts (data fork fonts). Unlike the TrueType fonts in earlier Mac 

OS versions, dFonts contain all the font information; there is no 

additional resource fork. While these are high-quality fonts, they 

are not recommended for workflows where users might want to 

open the document on a Mac OS system earlier than Mac OS X. 

If a customer provides you with a file created in Mac OS X using 

dFonts, output the file from a Mac OS X system where the fonts 

are installed and activated. 

PostScript Type 1 fonts may have different font metrics than their 

identically named dFont counterparts, so if you try to substitute 

them for the dFonts, text may reflow. You may want to remove 

those dFonts that conflict with existing PostScript or TrueType 

fonts, such as Helvetica, GillSans, and ZapfDingbats. However, the 

fonts that are stored in the System/Library/Fonts folder, which is 

a locked system location, require special treatment. 

Mac OS X comes with the following dFonts installed in the 

/System/Library/Fonts folder: Apple LiGothic Medium, Apple-

Gothic, Courier, Geneva, Hei, Helvetica, Keyboard, LastResort, 

LucidaGrande, Monaco, Osaka, OsakaMono, Symbol, Times, 

and ZapfDingbats. Additionally, these fonts are installed in the 

/Library/Fonts folder: #Gungseouche, #HeadlineA, #Pcmy-

oungjo, #Pilgiche, AmericanTypewriter, Apple LiSung Light, 

AppleMyungjo, Baskerville, Beijing, BiauKai, BigCaslon, Char-

coalCY, Cochin, Copperplate, Didot, Fang Song, Futura, Gene-

vaCY, GillSans, HelveticaCY, HelveticaNeue, Herculanum, Kai, 

MarkerFelt, MonacoCY, Optima, Papyrus, Seoul, Song, Taipei, 

TimesCY, Zapfino.

http://www.adobe.com/type/opentype
http://www.adobe.com/type/opentype
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typographic features are involved that require CID encoding. Addi-

tionally, Adobe fonts allow embedding, so they can be fully compliant 

with PDF/X workflows.

To preserve font styles when you import a document, InDesign has 

extended its Microsoft Word import options. 

InDesign CS2, Illustrator CS2, and Photoshop CS2 all provide Open-

Type layout feature support. You can turn on OpenType layout features 

that automatically substitute alternate glyphs in an OpenType font, 

such as automatic ligatures, small capitals, and proportional oldstyle 

figures.

Certain layout features have some effect on all fonts, whether they are 

OpenType or not: ligatures, all capitals, and small capitals; those fea-

tures are on the main InDesign Character palette menu. However, most 

OpenType layout features are available either through the OpenType 

submenu of the Character palette menu (InDesign CS2) or from the 

OpenType palette (Illustrator CS2). 

Note: Selecting Superscript or Subscript from the Character palette 

menu creates these glyphs by scaling full-size numbers, even if the 

selected font contains designed superscript or subscript glyphs. To 

use the designed glyphs for your font, use the Superscript/Superior 

or Subscript/Inferior options on the OpenType submenu or palette. 

If the OpenType superscript/subscript feature has no effect, or only 

affects some of the characters, the font does not support OpenType 

superscript/subscript for the particular characters in question, and 

you should use the generic version of the feature from the Character 

palette. 

To apply OpenType layout features in InDesign or Photoshop:

1.	 Click an insertion point to create new text, or select existing text.

2.	 Select an OpenType font.

3.	 Select formatting options from the Character palette menu or, in 

InDesign, its OpenType submenu. A check mark appears next to a 

feature when it’s enabled. A dash next to a feature means that you 

have selected a block of text that has the feature applied to some 

of the text. If a feature appears in brackets, the selected fonts does 

not support that feature.

To apply OpenType layout features in Illustrator CS2:

1.	 Click an insertion point to create new text, or select existing text.

2.	 Select an OpenType font.

3.	 Select formatting items from the Character palette menu or the 

OpenType palette. 

In the Character palette menu, a check mark indicates that a feature 

is enabled. In the palette, the selection boxes show the current state of 

the figure type and position. Features that have icons and are turned 

on are highlighted in the palette; icons cannot be selected if they are 

not supported in the selected font. 

R e s o u rc  e s

For more information about type and typography, in general, Adobe 

fonts, OpenType fonts, and type in Adobe Creative Suite 2, see the 

following resources:

“Typblography” - http://blogs.adobe.com/typblography

Thomas Phinney, Adobe program manager for fonts and core tech-

nologies, writes semi-regularly about the technical, business, historical, 

and design aspects of type and fonts, especially related to Adobe’s type 

development. 

“Advanced Typography with Mac OS X Tiger”

http://images.apple.com/pro/pdf/L311277A_FontTT_v4.pdf

Apple provides detailed information about fonts in Mac OS X Tiger

“OpenType User Guide for Adobe Fonts”

 http://store.adobe.com/type/browser/pdfs/OTGuide.pdf

This user guide provides information about installing, managing, and 

working with Adobe OpenType fonts.

Adobe Type Reference Guide, OpenType Edition 

http://store.adobe.com/store/products/master.jhtml?id=catATLBook

This book, available for purchase, is a 300-page visual reference that 

displays all Adobe Type Library fonts, as well as providing useful infor-

mation about the OpenType font format, typographic classifications, 

and character sets. 

Continued from page 3
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Technical Solutions
technical news and known issues for ASN service providers

Information about each of these issues is available in Adobe’s online 

technical support database. The links will take you directly to the 

“living documents”—information that is kept current by Adobe 

Technical Support staff. Issues that are platform-specific are preceded 

by MAC or WIN. You can read about issues that have the Adobe logo 

 next to them by clicking the URL. To search for information about 

other issues in the technical support database, visit http://www.adobe.

com/support/main.html. To find issues that appear in ReadMe Now, 

type RMN or ReadMe Now along with other search criteria (e.g., 

InDesign) into the search field. For tips on searching the database, 

visit http://www.adobe.com/search/searchtips.html.

Adobe Creative Suite Solutions

 Applications do not display properly on OEM computers (Creative 
Suite 2 on Windows)

http://www.adobe.com/support/techdocs/331827.html

Illustrator® Solutions

Error “Fail to install due to an error” when you install Illustrator CS2 
12.0.1 update

http://www.adobe.com/support/techdocs/332379.html

Issue 

When you install the Illustrator CS2 12.0.1 update, you receive the 

error message “Fail to install due to an error,” and the update does 

not install. 

Details 

You moved or renamed an Illustrator CS2 file or files before running 

the updater. For example, you removed the Read Me file or ran a main-

tenance utility that removed Illustrator foreign language files. 

Solution

Reinstall Illustrator CS2, and then install the updater again. 

Background information 

The 12.0.1 updater checks for the files that it is replacing before it 

installs. If the files have been moved or renamed, the update does not 

install correctly.

Error: “Could not complete the requested operation” when you start 
Illustrator CS2 (Mac OS)

http://www.adobe.com/support/techdocs/326194.html

Issue 

When you start Illustrator CS2, Illustrator returns the error message, 

“Could not complete the requested operation” and Illustrator crashes 

after you click OK. 

Details 

You moved the Illustrator application file from the Illustrator Appli-

cation folder. 

Solution

Move the Adobe Illustrator CS2 application file back to the Applica-

tions/Adobe Illustrator CS2 folder. 

Background information 

If the Illustrator application file isn’t in the Illustrator application 

folder, Illustrator will not start. If you want to start Illustrator from 

a different folder, such as the desktop, you must use an alias for the 

Illustrator application file. 

To make an alias of the Illustrator application file: 

1.	 Open the Illustrator application folder, and select the Illustrator 

application file. 

2.	 Choose File > Make Alias. 

InDesign® Solutions

Adobe InDesign 4.01 and Adobe InCopy CS2 4.0.1 updates available

http://www.adobe.com/support/downloads/main.html

Updates are available for InDesign CS2 and InCopy CS2.	

For a list of issues resolved by the Adobe InDesign CS2 4.0.1 update, see 

http://www.adobe.com/special/indesign/id401update/Adobe_InDe-

sign_CS2_4.0.1_ReadMe.pdf  

	 For a list of issues resolved by the Adobe InCopy 4.0.1 update, 

see http://www.adobe.com/special/incopy/ic401_update/Adobe_

InCopy_CS2_4.0.1_ReadMe.pdf .

Continued on page 6

http://www.adobe.com/support/main.html
http://www.adobe.com/support/main.html
http://www.adobe.com/search/searchtips.html
http://www.adobe.com/special/indesign/id401update/Adobe_InDesign_CS2_4.0.1_ReadMe.pdf
http://www.adobe.com/special/indesign/id401update/Adobe_InDesign_CS2_4.0.1_ReadMe.pdf
http://www.adobe.com/special/incopy/ic401_update/Adobe_InCopy_CS2_4.0.1_ReadMe.pdf
http://www.adobe.com/special/incopy/ic401_update/Adobe_InCopy_CS2_4.0.1_ReadMe.pdf
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Set a spot color to overprint in InDesign (CS2, CS, 2.x)

http://www.adobe.com/support/techdocs/323659.html

Some applications allow you to specify an overprint setting for a specific 

color. InDesign cannot define a spot color to overprint by default (that 

is, via settings in the Swatches palette or the Ink Manager). However, 

you can set Fill and Stroke to overprint for selected objects or set text 

to overprint in the Paragraph Style palette. 

By default, InDesign knocks out overlapping colors, except for black, 

which is set to overprint. 

Workarounds 

Your design work flow may require a certain color to be set to overprint. 

For example, you want to print all the text in your publication in a spe-

cific color, or you have a reoccurring object that contains this color. 

The following are some tips or workarounds for this situation: 

1.	 Create a separate layer for objects that contain your spot color and 

assign them to black. 

	 Black is set to overprint by default in InDesign. You can set a layer 

to overprint by assigning it to black, and then assign your spot 

color to this layer when you export to PDF: 

a.	 Open the Preferences dialog box: 

	 – In InDesign CS2, choose Edit > Preferences > Appearance 

Of Black (Windows) or InDesign > Preferences > Appear-

ance Of Black (Mac OS). 

	 – In InDesign CS or 2.x, choose Edit > Preferences > General 

> Print Options (Windows) or InDesign > Preferences > 

General > Print Options (Mac OS). 

b.	 Select Overprint [Black] Swatch At 100% (InDesign CS2 or 

CS) or Overprint Black (InDesign 2.x), and then click OK. 

c.	 Place the objects you want to overprint on a separate layer 

and assign them to black. 

d.	 When you are ready to print separations, hide all other layers 

and export to PDF. 

Note: When you give the PDF files to the printer, indicate which spot 

color should be assigned to each file. 

2.	 Assign a paragraph style with overprint settings. 

	 To assign a spot color to text and have the text always overprint: 

a.	 In the Paragraph Style palette, double-click on the desired 

Paragraph Style. 

b.	 In the Paragraph Style Options dialog box, select Character 

Color, and then select your spot color. 

c.	 Select the Overprint Fill box. 

d.	 Click OK to apply the paragraph style. 

3.	 Create a composite PDF file in InDesign and use a third-party 

Acrobat plug-in (for example, ARTS PDF Crackerjack) to apply 

overprint settings to colors within Adobe Acrobat. 

4.	 Assign overprint settings in your RIP. 

	 Many RIP devices allow you to assign overprint settings to a color 

for printing. Refer to your RIP documentation for information 

about overprinting options. 

5.	 Apply overprint settings to an image or object, and then add it to 

your library. 

	 If you have a reoccurring image that contains the spot color you 

want to overprint: 

a.	 Create the image, and then select the object or text that 

contains the color you want to overprint. 

b.	 Choose Window > Attributes to open the Attributes palette, 

and select Overprint Fill and/or Overprint Stroke. 

c.	 Save your design and add it to one of your libraries. You 

can then add the image from your library to any document 

without having to reset the overprint options. 

6.	 Edit a placed file in its original application. 

	 If you place an Illustrator or Photoshop file into your InDesign 

publication and you want colors to overprint, do the following: 

a.	 Open the file in its original application and set the overprint 

options there. 

b.	 In InDesign, update the link to the file in the Links palette. 

	 For more information about setting overprint options within vari-

ous applications, consult the application user guides or Help. 

Error “file name too long...” when you export InCopy stories (InDesign 
CS, CS2 on Mac OS X)

http://www.adobe.com/support/techdocs/332200.html

Issue 

When you export multiple stories to InCopy from InDesign, InDesign 

returns the error message, “Error - cannot copy the file [file name] . 

File name too long or invalid character.” 

Detail 

You are exporting files to an AFP server. 

Solution 1

Use NFS shares instead of AFP to connect a Mac OS X system to a 

Windows server. 

Solution 2 

When you manually export each story, you can name the story without 

creating a file name that is too long. 

Continued from page 5

Continued on page 7
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To export a story manually: 

1.	 In InDesign, select a story with either the Selection tool or the Text 

tool. 

2.	 Choose Edit > InCopy > Export > Selection (InDesign CS2) or 

Edit > InCopy Stories > Export Selected Stories (InDesign CS). 

3.	 Choose a destination for the story and give it a name. Click the 

Save button. 

Background information 

When multiple InCopy stories are exported in InDesign format, part 

of the story name is added to the file name so that you can differenti-

ate the exported files. 

The AFP protocol has a 31-character file name limit. InCopy stories 

with appended file names typically exceed this limit.

Name of exported EPS file doesn’t match document (InDesign CS2)

http://www.adobe.com/support/techdocs/331721.html

Issue 

When you export files from Adobe InDesign CS2, the EPS file names 

don’t match the document. Section names and page ranges are trun-

cated or ignored. 

For example, when you export pages 5-7 of Section 2 of a document 

from InDesign CS, the resulting files are named Section_2_5.eps, 

Section_2_6.eps, and Section_2_7.eps. Performing the same task in 

InDesign CS2 creates files named 21.eps, 22.eps, and 23.eps. 

Solution 1

Use Adobe Bridge to rename the files. 

1.	 Start Bridge and navigate to the folder containing the files you 

want to rename. 

2.	 Select the files, and choose Tools > Batch Rename. 

3.	 Choose the appropriate settings, and then click Rename. 

Solution 2 

Use a third-party utility to change the name of the EPS files. 

Solution 3 

Manually rename the EPS files in Windows Explorer or Mac OS X 

Finder.

Error: “Error in...Line 1:...IO Error” when you start (InDesign CS2 4.0.1 on 
Mac OS X)

http://www.adobe.com/support/techdocs/326800.html

Issue 

When you try to start Adobe InDesign CS2 4.0.1, InDesign displays 

the error message, “Error in. Line 1: IO Error.” 

Detail 

You logged in as a standard user. 

Solution

In InDesign CS2, choose Help > Updates and follow the prompts in 

the Adobe Update Manager to download and install the following 

updates: 

– Adobe Library 1 Update for Bridge Scripts 

– Adobe Photoshop Service Update 

Background information 

Previous versions of the Adobe Library 1 Update for Bridge Scripts 

and Adobe Photoshop Service Update changed the permissions of the 

Library/Application Support/Adobe/Startupscripts directory. The new 

versions of these updates fix that issue. 

 Troubleshoot damaged InDesign CS2 documents

http://www.adobe.com/support/techdocs/331678.html

 Crash, freeze, or unexpected shutdown while you work in InDesign 
CS2 (Mac OS and Windows)

http://www.adobe.com/support/techdocs/320210.html

PageMaker® Solutions

Error “...Bad record index” or graphic link information is missing in 
PageMaker 7.0.x

http://www.adobe.com/support/techdocs/330384.html

Issue 

When you choose File > Links in Adobe PageMaker 7.0.x, PageMaker 

returns the error “Cannot process publication’s links. Internal error: 

Bad record index. 8401:20515,” or link information for one or more 

imported graphics is missing in the Links dialog box. 

Details 

You performed a diagnostic recompose on the publication. 

One or more imported graphics is located on a master page. 

Solution

Create a backup copy of the publication, and then remove imported 

graphics from the master pages before performing a diagnostic 

recompose: 

1.	 Choose File > Save As, rename the publication, and then click 

Save. 

2.	 Remove all imported graphics located on master pages by deleting 

them or moving them onto the pasteboard or publication pages. 

3.	 Select the Pointer tool, and then press Shift + Option and choose 

Type > Hyphenation to perform a diagnostic recompose. 

4.	 Replace the graphics on the master pages. 

Background information 

When you perform a diagnostic recompose in a PageMaker 7.0.x 

publication that contains one or more imported graphics on a master 

Continued from page 6

Continued on page 8
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page, PageMaker 7.0.x deletes the link information for the master page 

graphics, causing the error “Cannot process publication’s links. Internal 

error: Bad record index. 8401:20515” to occur when you choose File 

> Links, or causing link information for the master page graphics to 

be missing in the Links dialog box. 

Missing link information also prevents the publication’s file size from 

decreasing as expected when you choose Save As or when you save the 

publication with the Smaller Save option selected in the Preferences 

dialog box. 

PageMaker 7.x crashes after you install Adobe Creative Suite 2 or 
Illustrator CS2 (Windows)

http://www.adobe.com/support/techdocs/332380.html

Issue 

After you install Adobe Creative Suite 2 or Adobe Illustrator CS2, Adobe 

PageMaker 7.x crashes when you open existing PageMaker files and 

returns one of the following error messages: 

– “Error: Adobe PageMaker has encountered a problem and needs 

to close.” 

–  “The instruction at ##### referenced memory at location ##### and 

the memory could not be read.” 

Solution

Delete the Dialog9.fon and Ruler.fon files: 

1.	 Go to Program Files\Adobe\Adobe Illustrator CS2\Support Files\

Contents\Windows\System. 

2.	 Delete the following files that appear in the folder: 

	 Dialog9.fon 

	 Ruler.fon 

3.	 Restart the computer. 

Background information 

The Dialog9.fon and Ruler.fon files are installed by Adobe Illustrator 

CS2 and cause a conflict with Adobe PageMaker 7.x. Illustrator CS2 

does not require these files, so you can safely remove them without 

affecting Illustrator CS2. 

Photoshop® Solutions

Transfer Photoshop CS actions to Photoshop CS2

http://www.adobe.com/support/techdocs/332256.html

Adobe Photoshop doesn’t save individual actions, you can only save 

actions as part of an action set. To transfer actions from Photoshop 

CS to Photoshop CS2, put the actions you want to save in their own 

action set in Photoshop CS, export the action set, then import that 

action set into Photoshop CS2. 

To export actions from Photoshop CS: 

1.	 In the Actions Palette, select the action set you want to export. 

2.	 In the palette menu, choose Save Actions. 

3.	 Specify a destination to save the ATN.atn file. to 

4.	 Click Save. 

To import actions into Photoshop CS2: 

1.	 In the Actions Palette palette menu select Load Actions. 

2.	 Navigate to the folder where you saved the exported action set. 

3.	 Select the action (ATN) file. 

4.	 Click Load. 

Photoshop CS2 crashes when you start or when you open or save an 
image (Mac OS X v10.3 and v10.4)

http://www.adobe.com/support/techdocs/332313.html

Issue 

When you start Adobe Photoshop CS2, or when you open or save an 

image, the application crashes, freezes, or quits with the error message, 

“The application Adobe Photoshop has unexpectedly quit.” 

Solution 1

Troubleshoot Mac OS. Different factors can cause system errors, 

including conflicts among device drivers, software, and hardware, and 

corrupt elements in specific files. Although a system error may occur 

only when you work with Photoshop, Photoshop may not necessarily 

be the cause--it may be the only application that uses enough memory 

or processor cycles to expose the problem. See Related Documents for 

the Photoshop CS2 system troubleshooting guide. 

Solution 2

Reduce the number of applications running while you run Photoshop 

CS2. 

Background information 

A number of system-related factors can cause Photoshop to crash, 

such as bad RAM, a problem with the hard disk, device drivers or other 

installed software. A problem with the Version Cue file manager within 

Photoshop, which cannot be disabled, may also cause Photoshop to 

crash in some circumstances.

 Optimize performance of Photoshop (CS2 on Windows)

http://www.adobe.com/support/techdocs/332271.html

 Optimize performance in Photoshop (CS2 on Mac OS)

http://www.adobe.com/support/techdocs/332270.html

Continued from page 7
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Resources
extend and enhance your Adobe applications

There are so many plug-ins, educational products, and other resources 

available for working with Adobe applications that it can be challeng-

ing to find those appropriate to streamline your particular workflow. 

To assist you, each month we feature resources we think you’ll find 

useful.

Adobe sells third-party plug-ins on its website at  

http://www.adobe.com/products/plugins/main.html.

Adobe provides many training resources on its website at  

http://www.adobe.com/misc/training.html.

Adobe PDF Library

Datalogics 

http://www.datalogics.com/pdflibrary-product.asp

The Adobe® PDF Library™, available through Datalogics, adds robust 

PDF creation, manipulation, and display capabilities to software 

applications. It is a developer’s toolkit that enables an application to 

create Adobe-compliant PDF output directly to a file or output device 

without the need for distillation or click-and-drag third-party PDF 

conversion utilities. 

The Adobe PDF Library uses the same core PDF technology upon 

which Adobe® Acrobat® is built. The Adobe PDF Library facilitates 

complex publishing and document workflows, and is ideal for embed-

ding Adobe PDF capabilities into server applications that require high-

performance Adobe PDF processing. Using the Adobe PDF Library, 

your applications can dynamically generate, manipulate, access, and 

print Adobe PDF documents in multithreaded server environments. 

The Adobe PDF Library is licensed to OEMs, Independent Software 

Vendors (ISVs), system integrators, and enterprise IT customers 

and partners. When you purchase the Adobe PDF Library through 

Datalogics, you automatically get the Datalogics Interface (DLI). This 

interface allows the application to decrease creation time for complex 

PDF documents. In addition, it facilitates PDF creation by reducing 

redundant functions occurring in the Adobe PDF Library. 

By purchasing the Adobe PDF Library through Datalogics, your PDF 

output is guaranteed to be suitable for future versions of Adobe® 

Reader®.

The Adobe PDF Library is available on the following platforms through 

Datalogics: Windows, Macintosh OS X, Macintosh on Intel , Sun Solaris 

(32-& 64-bit), Linux, HP IA32/IA64 (Itanium), HP PA-RISC (32-& 

64-bit), IBM AIX, IBM AS/400, IBM MVS (OS/390), IBM USS, SGI 

IRIX, Tru64 UNIX, Free BSD (UNIX), and zSeries (OS/390)

For more information about purchasing the Adobe PDF Library 

through Datalogics, please visit www.datalogics.com or call 

312.853.8200.

http://www.adobe.com/products/plugins/main.html
http://www.adobe.com/misc/training.html
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